بازگشت   پی سی سیتی > کامپیوتر اینترنت و شبکه Computer internet > نرم افزار - سخت افزار و بازیهای کامپیوتری

نرم افزار - سخت افزار و بازیهای کامپیوتری در این تالار مباحث مرتبط با نرم افزار های کاربردی دانلود برنامه های جدید سخت افزار قیمت ها تازه ترینهای بازار و نیز بازیهای رایانه ای دانلود کدهای تقلب و سایر موارد قرار میگیرد

پاسخ
 
ابزارهای موضوع نحوه نمایش
  #1  
قدیمی 01-09-2012
maniya1 maniya1 آنلاین نیست.
تازه کار
 
تاریخ عضویت: Dec 2011
محل سکونت: تهران
نوشته ها: 9
سپاسها: : 2

5 سپاس در 4 نوشته ایشان در یکماه اخیر
پیش فرض پرسش و پاسخ در مورد کریستال ریپورت

با سلام من فکر کردم که جای پرسش و پاسخ در مورد کریستال ریپورت در این سایت خالیه و به همین دلیل این تایپیک رو ایجاد کردم

من از کد ساده زیر برای گزارش گیری توسط کریستال ریپورت استفاده کردم وپیغام خطای زیر رو داد
public Form1( string name,string family)
{
InitializeComponent();
DataSet1 ds = new DataSet1();
DataRow br = ds.Tables[0].NewRow();
br["name"]=name;
br["family"]=family;
ds.Tables[0].Rows.Add(br);
ReportDocument rd = new ReportDocument();
rd.Load(@"c:\users\maniya\documents\visual studio 2010\Projects\cr2\cr2\CrystalReport1.rpt");
rd.SetDataSource(ds);
crystalReportViewer1.ReportSource = rd;
}
public Form2()
{
InitializeComponent();
}
private void button1_Click(object sender, EventArgs e)
{
Form1 fr = new Form1(textBox1.Text, textBox2.Text);
fr.ShowDialog();
}
پیغام خطا :
Could not load file or assembly 'file:///C:\Program Files (x86)\SAP BusinessObjects\Crystal Reports for .NET Framework 4.0\Common\SAP BusinessObjects Enterprise XI 4.0\win32_x86\dotnet1\crdb_adoplus.dll' or one of its dependencies. The system cannot find the file specified
و زمانی که فایل کریستال ریپورت برنامه رو در bin->debug گذاشتم باز پیغام load report failed داد
شما فکر میکنید اشکال این خطا از کجاست؟
با تشکر
پاسخ با نقل قول
کاربران زیر از maniya1 به خاطر پست مفیدش تشکر کرده اند :
جای تبلیغات شما اینجا خالیست با ما تماس بگیرید




  #2  
قدیمی 01-10-2012
maniya1 maniya1 آنلاین نیست.
تازه کار
 
تاریخ عضویت: Dec 2011
محل سکونت: تهران
نوشته ها: 9
سپاسها: : 2

5 سپاس در 4 نوشته ایشان در یکماه اخیر
پیش فرض

من خودم علت وجود این مشکل و راه حل اون رو پیدا کردم
این مشکل زمانی رخ میده که ما پروژه رو به .net fram work4میبریم و برای حل این مشکل کافی است در فایل appconfig کد رو به شکل زیر تغییر بدیم
<?xml version="1.0"?>
<configuration>

<startup useLegacyV2RuntimeActivationPolicy="true">

<supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/>
</startup>
</configuration>
من که با این تغییر مشکلم حل شد



پاسخ با نقل قول
کاربران زیر از maniya1 به خاطر پست مفیدش تشکر کرده اند :
پاسخ


کاربران در حال دیدن موضوع: 1 نفر (0 عضو و 1 مهمان)
 
ابزارهای موضوع
نحوه نمایش

مجوز های ارسال و ویرایش
شما نمیتوانید موضوع جدیدی ارسال کنید
شما امکان ارسال پاسخ را ندارید
شما نمیتوانید فایل پیوست در پست خود ضمیمه کنید
شما نمیتوانید پست های خود را ویرایش کنید

BB code is فعال
شکلک ها فعال است
کد [IMG] فعال است
اچ تی ام ال غیر فعال می باشد



اکنون ساعت 04:45 PM برپایه ساعت جهانی (GMT - گرینویچ) +3.5 می باشد.



Powered by vBulletin® Version 3.8.4 Copyright , Jelsoft Enterprices مدیریت توسط کورش نعلینی
استفاده از مطالب پی سی سیتی بدون ذکر منبع هم پیگرد قانونی ندارد!! (این دیگه به انصاف خودتونه !!)
(اگر مطلبی از شما در سایت ما بدون ذکر نامتان استفاده شده مارا خبر کنید تا آنرا اصلاح کنیم)


سایت دبیرستان وابسته به دانشگاه رازی کرمانشاه: کلیک کنید




  پیدا کردن مطالب قبلی سایت توسط گوگل برای جلوگیری از ارسال تکراری آنها